BaseFormat Class
Beta
A base Format class with shared properties and functionality between quantity and ecschema-metadata Format classes
Extended by
Methods
Name | Description | |
---|---|---|
constructor(name: string): BaseFormat | ||
hasFormatTraitSet(formatTrait: FormatTraits): boolean | This method returns true if the formatTrait is set in this Format object. | |
loadFormatProperties(formatProps: FormatProps): void | ||
parseFormatTraits(formatTraitsFromJson: string | string[]): void | This method parses input string that is typically extracted for persisted JSON data and validates that the string is a valid FormatType. |
Properties
Name | Type | Description | |
---|---|---|---|
_decimalSeparator Protected | string | ||
_formatTraits Protected | FormatTraits | ||
_includeZero Protected | boolean | ||
_minWidth Protected | undefined | number | ||
_precision Protected | number | ||
_roundFactor Protected | number | ||
_scientificType Protected | undefined | ScientificType | ||
_showSignOption Protected | ShowSignOption | ||
_spacer Protected | string | ||
_stationOffsetSize Protected | undefined | number | ||
_stationSeparator Protected | string | ||
_thousandSeparator Protected | string | ||
_type Protected | FormatType | ||
_uomSeparator Protected | string | ||
decimalSeparator Accessor | string | ||
formatTraits Accessor | FormatTraits | ||
includeZero Accessor | undefined | boolean | ||
minWidth Accessor | undefined | number | ||
name Accessor ReadOnly | string | ||
precision Accessor | DecimalPrecision | FractionalPrecision | ||
roundFactor Accessor | number | ||
scientificType Accessor | undefined | ScientificType | ||
showSignOption Accessor | ShowSignOption | ||
spacer Accessor | undefined | string | ||
stationOffsetSize Accessor | undefined | number | ||
stationSeparator Accessor | string | ||
thousandSeparator Accessor | string | ||
type Accessor | FormatType | ||
uomSeparator Accessor | string |
Defined in
- quantity/src/Formatter/Format.ts Line 23
Last Updated: 20 June, 2023