RenderSchedule.ModelTimelineProps Interface
JSON representation of a RenderSchedule.ModelTimeline.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
elementTimelines | RenderSchedule.ElementTimelineProps[] | Timelines affecting groups of elements. | |
modelId | string | The Id of the GeometricModelState to which the timeline applies. | |
realityModelUrl | undefined | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
colorTimeline | undefined | RenderSchedule.ColorEntryProps[] | RenderSchedule.TimelineProps | Timeline controlling the colors of the associated geometry. |
cuttingPlaneTimeline | undefined | RenderSchedule.CuttingPlaneEntryProps[] | RenderSchedule.TimelineProps | Timeline applying ClipVectors to the associated geometry. |
transformTimeline | undefined | RenderSchedule.TransformEntryProps[] | RenderSchedule.TimelineProps | Timeline applying transforms to the associated geometry. |
visibilityTimeline | undefined | RenderSchedule.VisibilityEntryProps[] | RenderSchedule.TimelineProps | Timeline controlling the visibility of the associated geometry. |
Defined in
- core/common/src/RenderSchedule.ts Line 164
Last Updated: 20 June, 2023