RenderSchedule.TimelineProps Interface
JSON representation of a RenderSchedule.Timeline.
Properties
Name | Type | Description | |
---|---|---|---|
colorTimeline | undefined | RenderSchedule.ColorEntryProps[] | Timeline controlling the colors of the associated geometry. | |
cuttingPlaneTimeline | undefined | RenderSchedule.CuttingPlaneEntryProps[] | Timeline applying ClipVectors to the associated geometry. | |
transformTimeline | undefined | RenderSchedule.TransformEntryProps[] | Timeline applying transforms to the associated geometry. | |
visibilityTimeline | undefined | RenderSchedule.VisibilityEntryProps[] | Timeline controlling the visibility of the associated geometry. |
Defined in
- core/common/src/RenderSchedule.ts Line 140
Last Updated: 20 June, 2023