RenderSchedule.ElementTimelineProps Interface
JSON representation of an RenderSchedule.ElementTimeline.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
batchId | number | A positive integer that uniquely identifies this timeline among all element timelines in the RenderSchedule.Script. | |
elementIds | string | string[] | The Ids of the elements to which this timeline applies. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
colorTimeline | undefined | RenderSchedule.ColorEntryProps[] | RenderSchedule.TimelineProps | Timeline controlling the colors of the associated geometry. |
cuttingPlaneTimeline | undefined | RenderSchedule.CuttingPlaneEntryProps[] | RenderSchedule.TimelineProps | Timeline applying ClipVectors to the associated geometry. |
transformTimeline | undefined | RenderSchedule.TransformEntryProps[] | RenderSchedule.TimelineProps | Timeline applying transforms to the associated geometry. |
visibilityTimeline | undefined | RenderSchedule.VisibilityEntryProps[] | RenderSchedule.TimelineProps | Timeline controlling the visibility of the associated geometry. |
Defined in
- core/common/src/RenderSchedule.ts Line 152
Last Updated: 20 June, 2023