TypeEditor Interface
Interface implemented by React based type editors
Implemented by
- BooleanEditor
- EnumButtonGroupEditor
- EnumEditor
- ImageCheckBoxEditor
- NumericInputEditor
- SliderEditor
- TextEditor
- TextareaEditor
- ThemedEnumEditor
- ToggleEditor
Methods
Name | Description | |
---|---|---|
getPropertyValue(): Promise<undefined | PropertyValue> |
Properties
Name | Type | Description | |
---|---|---|---|
hasFocus | boolean | ||
htmlElement | | HTMLElement |
Defined in
Last Updated: 20 June, 2023