ImageCheckBoxEditor Class
ImageCheckBoxEditor Boolean editor that renders with an image instead of checkbox
Extends
- PureComponent<PropertyEditorProps, ImageCheckBoxEditorState>
Implements
Methods
Name | Description | |
---|---|---|
constructor(props: PropertyEditorProps | Readonly<PropertyEditorProps>): ImageCheckBoxEditor | ||
constructor(props: PropertyEditorProps, context: any): ImageCheckBoxEditor | Deprecated | |
getPropertyValue(): Promise<undefined | PropertyValue> | ||
render(): Element |
Properties
Name | Type | Description | |
---|---|---|---|
hasFocus Accessor ReadOnly | boolean | ||
htmlElement Accessor ReadOnly | | HTMLElement |
Defined in
Last Updated: 20 June, 2023