ToggleEditor Class
ToggleEditor React component that is a property editor with checkbox input
Extends
- PureComponent<PropertyEditorProps, ToggleEditorState>
Implements
Methods
Name | Description | |
---|---|---|
constructor(props: PropertyEditorProps | Readonly<PropertyEditorProps>): ToggleEditor | ||
constructor(props: PropertyEditorProps, context: any): ToggleEditor | Deprecated | |
getPropertyValue(): Promise<undefined | PropertyValue> |
Properties
Name | Type | Description | |
---|---|---|---|
hasFocus Accessor ReadOnly | boolean | ||
htmlElement Accessor ReadOnly | | HTMLElement |
Defined in
Last Updated: 20 June, 2023