EnumButtonGroupEditor Class
EnumButtonGroupEditor React component that is a property editor with select input
Extends
- Component<PropertyEditorProps, EnumButtonGroupEditorState>
Implements
Methods
Name | Description | |
---|---|---|
constructor(props: PropertyEditorProps | Readonly<PropertyEditorProps>): EnumButtonGroupEditor | ||
constructor(props: PropertyEditorProps, context: any): EnumButtonGroupEditor | Deprecated | |
getPropertyValue(): Promise<undefined | PropertyValue> |
Properties
Name | Type | Description | |
---|---|---|---|
hasFocus Accessor ReadOnly | boolean | ||
htmlElement Accessor ReadOnly | | HTMLElement |
Defined in
Last Updated: 20 June, 2023