ThemedEnumEditor Class
Beta @deprecated in 3.0. Use EnumEditor.
EnumEditor React component that is a property editor with select input
Extends
- PureComponent<ThemedEnumEditorProps, EnumEditorState>
Implements
Methods
Name | Description | |
---|---|---|
constructor(props: ThemedEnumEditorProps | Readonly<ThemedEnumEditorProps>): ThemedEnumEditor | ||
constructor(props: ThemedEnumEditorProps, context: any): ThemedEnumEditor | Deprecated | |
getPropertyValue(): Promise<undefined | PropertyValue> |
Properties
Name | Type | Description | |
---|---|---|---|
hasFocus Accessor ReadOnly | boolean | ||
htmlElement Accessor ReadOnly | | HTMLElement |
Defined in
Last Updated: 20 June, 2023