ThemedEnumEditorProps Interface
Beta @deprecated in 3.0. Use EnumEditor.
Properties for ThemedEnumEditor component
Extends
Methods
Name | Description | |
---|---|---|
The function to return an error message used when the search string can't be found in the list |
Inherited methods
Name | Inherited from | Description |
---|---|---|
onBlur(event: FocusEvent<Element, Element>): void Optional | PropertyEditorProps | Handler for blur |
onCancel(): void Optional | PropertyEditorProps | Handler for cancel |
onCommit(args: PropertyUpdatedArgs): void Optional | PropertyEditorProps | Handler for commit |
Properties
Name | Type | Description | |
---|---|---|---|
isSearchable | undefined | boolean | Allow searching in enum list | |
placeholder | undefined | string | The prompt string used when no enum member has been selected |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | undefined | string | PropertyEditorProps | Custom CSS class name |
itemId | undefined | string | PropertyEditorProps | Optional unique identifier for item. |
propertyRecord | undefined | PropertyRecord | PropertyEditorProps | The property being updated. |
setFocus | undefined | boolean | PropertyEditorProps | Indicates whether the Property Editor should set focus |
style | undefined | CSSProperties | PropertyEditorProps | Custom CSS style properties |
Defined in
Last Updated: 20 June, 2023