TextEditor Class
TextEditor React component that is a property editor with text input
Extends
- PureComponent<PropertyEditorProps, TextEditorState>
Implements
Methods
Name | Description | |
---|---|---|
constructor(props: PropertyEditorProps | Readonly<PropertyEditorProps>): TextEditor | ||
constructor(props: PropertyEditorProps, context: any): TextEditor | Deprecated | |
getPropertyValue(): Promise<undefined | PropertyValue> |
Properties
Name | Type | Description | |
---|---|---|---|
hasFocus Accessor ReadOnly | boolean | ||
htmlElement Accessor ReadOnly | | HTMLElement |
Defined in
Last Updated: 20 June, 2023