Name |
Description |
|
CalculatedPropertiesSpecification |
This content modifier allows including additional calculated properties into the content. |
|
CheckBoxRule |
CheckBox rules provide a way to create a checkbox for specific types of ECInstance's. |
Deprecated |
ChildNodeRule |
Child node rules are used to define child nodes in a hierarchy. |
|
ChildNodeSpecificationBase |
Base interface for all ChildNodeSpecification implementations. |
|
ClassGroup |
Base class grouping allows grouping ECInstance nodes by their base class (as opposed to the hierarchy |
|
ConditionContainer |
Container of a ConditionContainer.condition property. |
Deprecated |
ContentInstancesOfSpecificClassesSpecification |
This specification creates content for all instances of specific ECClasses. |
|
ContentModifier |
Content modifiers are used to modify how instances of specified ECClasses are displayed in content which is |
|
ContentModifiersList |
Contains various rule attributes that allow modifying returned content. |
|
ContentRelatedInstancesSpecification |
Returns content for instances related to the selected (input) instances. |
|
ContentRule |
Content rules are used to define content that is displayed for specific type of input. |
|
ContentSpecificationBase |
Base interface for all ContentSpecification implementations. |
|
CustomNodeSpecification |
Returns a static custom-defined node that's not based on an ECInstance. |
|
CustomQueryInstanceNodesSpecification |
Returns nodes for instances returned by a provided ECSQL query. |
|
CustomRendererSpecification |
This specification allows defining a custom renderer, which can be used to render properties or categories. |
|
DefaultGroupingPropertiesContainer |
A container of default grouping properties. |
|
DefaultPropertyCategoryOverride |
A rule that allows overriding the default property category. |
|
DisabledSortingRule |
Rule to disable sorting for certain ECInstances in the hierarchy and/or content. |
|
ECPropertyValueQuerySpecification |
The specification specifies the name of the parent node instance property whose value is the ECSQL |
|
ExtendedDataRule |
Extended data rule is used to inject some arbitrary data into presentation data objects (nodes, content records). |
|
GroupingRule |
Grouping rules provide advanced ways to group instances when creating hierarchies. |
|
GroupingSpecificationBase |
Base interface for all GroupingSpecification implementations. |
|
IdCategoryIdentifier |
Identifier of a category specified through PropertyCategorySpecification in this scope. |
|
ImageIdOverride |
ImageId override rules allow setting an image ID to specific types of ECInstances. |
Deprecated |
InstanceLabelOverride |
Instance label override rule provides a way to set instance label to one of its property values, |
|
InstanceLabelOverrideBriefcaseIdSpecification |
Specification returns ECInstance's briefcase ID in base36 format. |
|
InstanceLabelOverrideClassLabelSpecification |
Specification uses ECClass display label as the label content. |
|
InstanceLabelOverrideClassNameSpecification |
Specification uses ECClass name as the label content. |
|
InstanceLabelOverrideCompositeValueSpecification |
Specification allows creating a label value composited using multiple other specifications. |
|
InstanceLabelOverrideLocalIdSpecification |
Specification returns ECInstance's local ID in base36 format. |
|
InstanceLabelOverridePropertyValueSpecification |
Specification uses property value as the label content. |
|
InstanceLabelOverrideRelatedInstanceLabelSpecification |
Specification uses label of another related instance as the label content. |
|
InstanceLabelOverrideStringValueSpecification |
Specification uses the specified value as the label content. |
|
InstanceLabelOverrideValueSpecificationBase |
Base interface for all InstanceLabelOverrideValueSpecification implementations. |
|
InstanceNodesOfSpecificClassesSpecification |
Returns nodes for instances of specific ECClasses. |
|
LabelOverride |
Label override rules provide advanced ways to override instance labels and descriptions in |
Deprecated |
MultiSchemaClassesSpecification |
This specification lists ECClasses which should be targeted when creating content or hierarchy nodes. |
|
NavigationRuleBase |
Base class for all NavigationRule implementations. |
|
NoCategoryIdentifier |
Identifier for no category. |
|
NodeArtifactsRule |
Node artifacts rules are used to create and assign artifacts to specific nodes. |
|
ParentCategoryIdentifier |
Identifier of the default parent category. |
|
PropertyCategorySpecification |
Content modifier for defining custom property categories. |
|
PropertyEditorJsonParameters |
Arbitrary JSON parameters for custom property editors |
|
PropertyEditorMultilineParameters |
Multiline parameters for property editors that support multiline display |
|
PropertyEditorParametersBase |
Base interface for PropertyEditorParameters. |
|
PropertyEditorRangeParameters |
Range parameters for property editors that support ranges |
|
PropertyEditorSliderParameters |
Slider parameters for property editors that support slider display |
|
PropertyEditorSpecification |
This specification allows assigning a custom property editor to specific properties. |
|
PropertyGroup |
Property grouping allows grouping by a property of the instance by value or by given ranges of values. |
|
PropertyOverrides |
A container structure for possible property overrides |
|
PropertyRangeGroupSpecification |
Describes a grouping range. |
|
PropertySortingRule |
Rule to configure sorting for certain ECInstances in the hierarchy and/or content. |
|
PropertySpecification |
This specification allows overriding some attributes of specific ECProperty or define how it's displayed. |
|
QuerySpecificationBase |
Base interface for all QuerySpecification implementations. |
|
RelatedInstanceNodesSpecification |
Produces ECInstance nodes that are related to some source ECInstance. |
|
RelatedInstanceSpecification |
Related instance specification is used in content |
|
RelatedPropertiesSpecification |
This specification allows including related instance properties into the content. |
|
RelationshipStepSpecification |
Specification of a single step in RelationshipPathSpecification. |
|
RepeatableRelationshipStepSpecification |
Specification of a single step in RepeatableRelationshipPathSpecification. |
|
RequiredSchemaSpecification |
This specification is designed for specifying schema requirements for the Ruleset or specific |
|
RootCategoryIdentifier |
Identifier of the root category. |
|
RootNodeRule |
Root node rules are used to define nodes that are displayed at the root hierarchy level. |
|
RuleBase |
Base interface for all Rule implementations. |
|
Ruleset |
Presentation ruleset is a list of rules that define tree hierarchy and content provided by |
|
SameLabelInstanceGroup |
Allows grouping multiple instances with the same label into one ECInstances type of node. |
|
SchemasSpecification |
Specification for a list of ECSchemas |
|
SelectedNodeInstancesSpecification |
Returns content for selected (input) instances. |
|
SingleSchemaClassSpecification |
This specification is used to point to specific ECClass. |
|
SortingRuleBase |
Sorting rules provide a way to either disable sorting or sort instances by specific properties. |
|
StringQuerySpecification |
The specification contains an ECSQL query which is used to query for instances. |
|
StyleOverride |
Style override rules allow customizing display style of specific types of ECInstances. |
Deprecated |
SubCondition |
This is a sub-rule which shares placement attributes and |
|
SupplementationInfo |
Contains supplementation-related information for |
|
Variable |
Definition for single user-controllable variable |
|
VariablesGroup |
Presentation rules support variables that allow having additional customization of the hierarchy |
|