CustomQueryInstanceNodesSpecification Interface
Returns nodes for instances returned by a provided ECSQL query.
see Custom query instance nodes specification reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
queries | undefined | QuerySpecification[] | Specifications of queries used to create the content. | |
specType | "CustomQueryInstanceNodes" | Used for serializing to JSON. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
doNotSort | undefined | boolean | ChildNodeSpecificationBase | Suppress sorting of nodes returned by this specification. |
groupByClass | undefined | boolean | DefaultGroupingPropertiesContainer | Controls whether returned instances should be grouped by ECClass. |
groupByLabel | undefined | boolean | DefaultGroupingPropertiesContainer | Controls whether returned instances should be grouped by label. |
hasChildren | "Always" | "Never" | "Unknown" | ChildNodeSpecificationBase | This attribute allows telling the engine that nodes created by this specification always or never have children. |
hideExpression | undefined | string | ChildNodeSpecificationBase | When specified ECExpression evaluates |
hideIfNoChildren | undefined | boolean | ChildNodeSpecificationBase | Specifies whether nodes created through this specification should be hidden if they have no child nodes. |
hideNodesInHierarchy | undefined | boolean | ChildNodeSpecificationBase | When true , instances nodes produced by this specification are omitted and their children appear one |
nestedRules | undefined | ChildNodeRule[] | ChildNodeSpecificationBase | Specifications of nested child node rules that |
priority | undefined | number | ChildNodeSpecificationBase | Controls the order in which specifications are handled — specification with higher priority value is |
relatedInstances | undefined | RelatedInstanceSpecification[] | ChildNodeSpecificationBase | Specifications of related instances that can be used |
suppressSimilarAncestorsCheck | undefined | boolean | ChildNodeSpecificationBase | Specifies whether similar ancestor nodes' checking should be suppressed when creating nodes based on this |
Defined in
- presentation/common/src/presentation-common/rules/hierarchy/CustomQueryInstanceNodesSpecification.ts Line 18
Last Updated: 20 June, 2023