ChildNodeSpecificationBase Interface
Base interface for all ChildNodeSpecification implementations.
see Child node specifications reference documentation section
Properties
Name | Type | Description | |
---|---|---|---|
doNotSort | undefined | boolean | Suppress sorting of nodes returned by this specification. | |
hasChildren | "Always" | "Never" | "Unknown" | This attribute allows telling the engine that nodes created by this specification always or never have children. | |
hideExpression | undefined | string | When specified ECExpression evaluates | |
hideIfNoChildren | undefined | boolean | Specifies whether nodes created through this specification should be hidden if they have no child nodes. | |
hideNodesInHierarchy | undefined | boolean | When true , instances nodes produced by this specification are omitted and their children appear one |
|
nestedRules | undefined | ChildNodeRule[] | Specifications of nested child node rules that | |
priority | undefined | number | Controls the order in which specifications are handled — specification with higher priority value is | |
relatedInstances | undefined | RelatedInstanceSpecification[] | Specifications of related instances that can be used | |
specType | "RelatedInstanceNodes" | "InstanceNodesOfSpecificClasses" | "CustomQueryInstanceNodes" | "CustomNode" | Used for serializing to JSON. | |
suppressSimilarAncestorsCheck | undefined | boolean | Specifies whether similar ancestor nodes' checking should be suppressed when creating nodes based on this |
Defined in
Last Updated: 20 June, 2023