PropertyCategorySpecification Interface
Content modifier for defining custom property categories. Custom categories are not present in the result unless they contain at least one property. One way to assign a property to the category is by using property overrides.
see Property category specification reference documentation page
Properties
Name | Type | Description | |
---|---|---|---|
autoExpand | undefined | boolean | Controls the value of CategoryDescription.expand which tells the UI component | |
description | undefined | string | Extensive description of the category. | |
id | string | Category identifier used to reference the category definition from property overrides or other category | |
label | string | Display label of the category. | |
parentId | string | NoCategoryIdentifier | CategoryIdentifier | Identifier of a parent category. | |
priority | undefined | number | Assign a custom CategoryDescription.priority to the category. | |
renderer | undefined | CustomRendererSpecification | Custom category renderer specification that allows |
Defined in
- presentation/common/src/presentation-common/rules/content/modifiers/PropertyCategorySpecification.ts Line 80
Last Updated: 20 June, 2023