InstanceLabelOverride Interface
Instance label override rule provides a way to set instance label to one of its property values, other attributes and/or combination of them.
see Instance label override reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
class | SingleSchemaClassSpecification | Specifies the ECClass to apply this rule to. | |
ruleType | "InstanceLabelOverride" | Used for serializing to JSON. | |
values | InstanceLabelOverrideValueSpecification[] | Specifications of values used to override label. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
onlyIfNotHandled | undefined | boolean | RuleBase | Tells the library that the rule should only be handled if no other rule of the same type was handled previously (based on rule |
priority | undefined | number | RuleBase | Defines the order in which rules are handled, higher number means the rule is handled first. |
requiredSchemas | undefined | RequiredSchemaSpecification[] | RuleBase | A list of ECSchema requirements that need to be met for the rule to be used. |
Defined in
Last Updated: 20 June, 2023