RuleBase Interface
Base interface for all Rule implementations.
Properties
Name | Type | Description | |
---|---|---|---|
onlyIfNotHandled | undefined | boolean | Tells the library that the rule should only be handled if no other rule of the same type was handled previously (based on rule | |
priority | undefined | number | Defines the order in which rules are handled, higher number means the rule is handled first. | |
requiredSchemas | undefined | RequiredSchemaSpecification[] | A list of ECSchema requirements that need to be met for the rule to be used. | |
ruleType | "Content" | "DefaultPropertyCategoryOverride" | "ContentModifier" | "CheckBox" | "ExtendedData" | "Grouping" | "ImageIdOverride" | "InstanceLabelOverride" | "LabelOverride" | "RootNodes" | "ChildNodes" | "PropertySorting" | "DisabledSorting" | "NodeArtifacts" | "StyleOverride" | Used for serializing to JSON. |
Defined in
Last Updated: 20 June, 2023