PropertyGroup Interface
Property grouping allows grouping by a property of the instance by value or by given ranges of values.
see Property grouping documentation section
Extends
Properties
Name | Type | Description | |
---|---|---|---|
createGroupForSingleItem | undefined | boolean | Specifies whether a grouping node should be created if there is only one item in that group. | |
createGroupForUnspecifiedValues | undefined | boolean | Should a separate grouping node be created for nodes whose grouping value is not set or is set to an empty string. | |
groupingValue | "PropertyValue" | "DisplayLabel" | Specifies whether instances should be grouped using property's display or raw value. | Deprecated |
imageId | undefined | string | Specifies grouping node's image ID. | |
propertyName | string | Name of the ECProperty which is used for grouping. | |
ranges | undefined | PropertyRangeGroupSpecification[] | Ranges into which the grouping values are divided. | |
sortingValue | "PropertyValue" | "DisplayLabel" | Specifies whether nodes should be sorted by their display label or the grouping property's value. | Deprecated |
specType | "Property" | Used for serializing to JSON. |
Defined in
Last Updated: 20 June, 2023