AuxCoordSystemSpatialState Class
The state of an AuxCoordSystemSpatial element in the frontend
extensions
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: AuxCoordSystem3dProps, iModel: IModelConnection): AuxCoordSystemSpatialState | Constructor for EntityState |
Inherited methods
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor StaticReadOnly | string | AuxCoordSystem3dState | Get full BIS class name of this Entity in the form "SchemaName:ClassName". |
classFullName Readonly | string | AuxCoordSystem3dState | The full class name in the form "schema:class". |
className Accessor ReadOnly | string | AuxCoordSystem3dState | The name of the BIS class associated with this class. |
code Readonly | Code | AuxCoordSystem3dState | The Code for this element |
description | undefined | string | AuxCoordSystem3dState | |
federationGuid Readonly | undefined | string | AuxCoordSystem3dState | A FederationGuid assigned to this element by some other federated database |
id Readonly | string | AuxCoordSystem3dState | The Id of this Entity. |
iModel Readonly | IModelConnection | AuxCoordSystem3dState | The iModel from which this Entity was loaded |
is3d Accessor ReadOnly | boolean | AuxCoordSystem3dState | |
jsonProperties Readonly | { T } | AuxCoordSystem3dState | Optional json properties of this Entity. |
model Readonly | string | AuxCoordSystem3dState | The ModelId of the Model containing this element |
origin Readonly | Point3d | AuxCoordSystem3dState | |
parent Readonly | undefined | RelatedElement | AuxCoordSystem3dState | The parent Element of this, or undefined if no parent. |
pitch | number | AuxCoordSystem3dState | |
roll | number | AuxCoordSystem3dState | |
schemaName Accessor StaticReadOnly | string | AuxCoordSystem3dState | The name of the BIS schema for this class. |
type | number | AuxCoordSystem3dState | |
userLabel Readonly | undefined | string | AuxCoordSystem3dState | A user-assigned label for this element. |
yaw | number | AuxCoordSystem3dState |
Defined in
- core/frontend/src/AuxCoordSys.ts Line 385
Last Updated: 20 June, 2023