GenericPhysicalMaterial Class
The Generic:PhysicalMaterial class is used when the physical material cannot be further classified.
note More-specific BisCore:PhysicalMaterial subclasses should be used wherever possible.
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: DefinitionElementProps, iModel: IModelDb): GenericPhysicalMaterial |
Inherited methods
Name | Inherited from | Description |
---|---|---|
collectPredecessorIds(predecessorIds: Id64Set): void Protected | PhysicalMaterial | Collect the Ids of this element's references at this level of the class hierarchy. |
collectReferenceIds(referenceIds: Set<string>): void Protected | PhysicalMaterial | Collect the Ids of this entity's references at this level of the class hierarchy. |
delete(): void | PhysicalMaterial | Delete this Element from the iModel. |
forEachProperty(func: PropertyCallback, includeCustom: boolean = true): void | PhysicalMaterial | Call a function for each property of this Entity. |
getClassMetaData(): undefined | EntityMetaData | PhysicalMaterial | Get the class metadata for this element. |
getDisplayLabel(): string | PhysicalMaterial | Get a display label for this Element. |
getJsonProperty(nameSpace: string): any | PhysicalMaterial | Get a JSON property of this element, by namespace |
getPredecessorIds(): Id64Set | PhysicalMaterial | Get the Ids of this element's references. |
getReferenceIds(): Set<string> | PhysicalMaterial | Get the Ids of this element's references. |
PhysicalMaterial | Get a list of HTML strings that describe this Element for the tooltip. | |
getUserProperties(namespace: string): any | PhysicalMaterial | Get a set of JSON user properties by namespace |
insert(): string | PhysicalMaterial | Insert this Element into the iModel. |
removeUserProperties(nameSpace: string): void | PhysicalMaterial | Remove a set of JSON user properties, specified by namespace, from this Element |
setJsonProperty(nameSpace: string, value: any): void | PhysicalMaterial | |
setUserProperties(nameSpace: string, value: any): void | PhysicalMaterial | Change a set of user JSON properties of this Element by namespace. |
update(): void | PhysicalMaterial | Update this Element in the iModel. |
create<T extends PhysicalMaterial<T>>(iModelDb: IModelDb, definitionModelId: string, name: string): T Static | PhysicalMaterial | Create a PhysicalMaterial |
createCode(iModel: IModelDb, definitionModelId: string, name: string): Code Static | PhysicalMaterial | Create a Code for a PhysicalMaterial given a name that is meant to be unique within the scope of the specified DefinitionModel. |
is(otherClass: undefined): boolean Static | PhysicalMaterial | return whether this Entity class is a subclass of another Entity class |
onAllInputsHandled(_id: string, _iModel: IModelDb): void ProtectedStatic | PhysicalMaterial | Called on an element in a graph after all of its inputs have been processed and before its outputs are processed. |
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void ProtectedStatic | PhysicalMaterial | Called when a root element in a subgraph is changed and before its outputs are processed. |
onChildAdd(_arg: OnChildElementPropsArg): void ProtectedStatic | PhysicalMaterial | Called when an existing element is about to be updated so that an instance of this class will become its new parent. |
onChildAdded(_arg: OnChildElementIdArg): void ProtectedStatic | PhysicalMaterial | Called after an existing element has been updated so that an instance of this class is its new parent. |
onChildDelete(_arg: OnChildElementIdArg): void ProtectedStatic | PhysicalMaterial | Called when an element with an instance of this class as its parent is about to be deleted. |
onChildDeleted(_arg: OnChildElementIdArg): void ProtectedStatic | PhysicalMaterial | Called after an element with an instance of this class as its parent was successfully deleted. |
onChildDrop(_arg: OnChildElementIdArg): void ProtectedStatic | PhysicalMaterial | Called when an element with an instance of this class as its parent is about to be updated change to a different parent. |
onChildDropped(_arg: OnChildElementIdArg): void ProtectedStatic | PhysicalMaterial | Called after an element with an instance of this class as its previous parent was updated to have a new parent. |
onChildInsert(_arg: OnChildElementPropsArg): void ProtectedStatic | PhysicalMaterial | Called when a new element with an instance of this class as its parent is about to be inserted. |
onChildInserted(_arg: OnChildElementIdArg): void ProtectedStatic | PhysicalMaterial | Called after a new element with an instance of this class as its parent was inserted. |
onChildUpdate(_arg: OnChildElementPropsArg): void ProtectedStatic | PhysicalMaterial | Called when an element with an instance of this class as its parent is about to be updated. |
onChildUpdated(_arg: OnChildElementIdArg): void ProtectedStatic | PhysicalMaterial | Called after an element with an instance of this the class as its parent was updated. |
onCloned(_context: IModelElementCloneContext, _sourceProps: ElementProps, _targetProps: ElementProps): void ProtectedStatic | PhysicalMaterial | Called during the iModel transformation process after an Element from the source iModel was cloned for the target iModel. |
onDelete(arg: OnElementIdArg): void ProtectedStatic | PhysicalMaterial | Called before an Element is deleted. |
onDeleted(_arg: OnElementIdArg): void ProtectedStatic | PhysicalMaterial | Called after an Element was deleted. |
onInsert(arg: OnElementPropsArg): void ProtectedStatic | PhysicalMaterial | Called before a new Element is inserted. |
onInserted(arg: OnElementIdArg): void ProtectedStatic | PhysicalMaterial | Called after a new Element was inserted. |
onSubModelDelete(_arg: OnSubModelIdArg): void ProtectedStatic | PhysicalMaterial | Called when a sub-model of an instance of this class is being deleted. |
onSubModelDeleted(_arg: OnSubModelIdArg): void ProtectedStatic | PhysicalMaterial | Called after a sub-model of an instance of this class was deleted. |
onSubModelInsert(_arg: OnSubModelPropsArg): void ProtectedStatic | PhysicalMaterial | Called when an instance of this class is being sub-modeled by a new Model. |
onSubModelInserted(_arg: OnSubModelIdArg): void ProtectedStatic | PhysicalMaterial | Called after an instance of this class was sub-modeled by a new Model. |
onUpdate(arg: OnElementPropsArg): void ProtectedStatic | PhysicalMaterial | Called before an Element is updated. |
onUpdated(_arg: OnElementIdArg): void ProtectedStatic | PhysicalMaterial | Called after an Element was updated. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor ReadOnly | string | PhysicalMaterial | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor StaticReadOnly | string | PhysicalMaterial | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor ReadOnly | string | PhysicalMaterial | The name of the BIS class associated with this class. |
code | Code | PhysicalMaterial | The Code for this element |
federationGuid | undefined | string | PhysicalMaterial | A FederationGuid assigned to this element by some other federated database |
id | string | PhysicalMaterial | The Id of this Entity. |
iModel | IModelDb | PhysicalMaterial | The IModelDb that contains this Entity |
isInstanceOfEntity Readonly | "true" | PhysicalMaterial | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
isPrivate | boolean | PhysicalMaterial | If true, don't show this DefinitionElement in user interface lists. |
jsonProperties Readonly | { T } | PhysicalMaterial | Optional json properties of this element. |
model Readonly | string | PhysicalMaterial | The ModelId of the Model containing this element |
parent | undefined | RelatedElement | PhysicalMaterial | The parent element, if present, of this element. |
requiredReferenceKeys StaticReadonly | undefined | PhysicalMaterial | A required reference is an element that had to be inserted before this element could have been inserted. |
schema Static | undefined | PhysicalMaterial | The Schema that defines this class. |
schemaName Accessor ReadOnly | string | PhysicalMaterial | The name of the BIS Schema that defines this class |
userLabel | undefined | string | PhysicalMaterial | A user-assigned label for this element. |
Defined in
Last Updated: 20 June, 2023