FunctionalModel Class
A container for persisting FunctionalElements.
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: ModelProps, iModel: IModelDb): FunctionalModel | ||
insert(iModelDb: IModelDb, parentSubjectId: string, name: string): string Static | Insert a FunctionalPartition and a FunctionalModel that breaks it down. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
collectReferenceIds(referenceIds: Set<string>): void Protected | RoleModel | Collect the Ids of this entity's references at this level of the class hierarchy. |
delete(): void | RoleModel | Delete this Model from the iModel. |
forEachProperty(func: PropertyCallback, includeCustom: boolean = true): void | RoleModel | Call a function for each property of this Entity. |
getJsonProperty(name: string): any | RoleModel | |
getReferenceIds(): Set<string> | RoleModel | Get the Ids of this element's references. |
getUserProperties(namespace: string): any | RoleModel | Get a set of JSON user properties by namespace |
insert(): string | RoleModel | Insert this Model in the iModel |
removeUserProperties(nameSpace: string): void | RoleModel | Remove a set of JSON user properties, specified by namespace, from this Element |
setJsonProperty(name: string, value: any): void | RoleModel | |
setUserProperties(nameSpace: string, value: any): void | RoleModel | Change a set of user JSON properties of this Element by namespace. |
update(): void | RoleModel | Update this Model in the iModel. |
is(otherClass: undefined): boolean Static | RoleModel | return whether this Entity class is a subclass of another Entity class |
onDelete(arg: OnModelIdArg): void ProtectedStatic | RoleModel | Called before a Model is deleted. |
onDeleteElement(_arg: OnElementInModelIdArg): void ProtectedStatic | RoleModel | Called when an Element in an instance of a Model of this class is about to be deleted. |
onDeleted(_arg: OnModelIdArg): void ProtectedStatic | RoleModel | Called after a Model was deleted. |
onDeletedElement(_arg: OnElementInModelIdArg): void ProtectedStatic | RoleModel | Called after an Element in an instance of a Model of this class has been deleted. |
onInsert(arg: OnModelPropsArg): void ProtectedStatic | RoleModel | Called before a new Model is inserted. |
onInsertElement(_arg: OnElementInModelPropsArg): void ProtectedStatic | RoleModel | Called before a prospective Element is to be inserted into an instance of a Model of this class. |
onInserted(_arg: OnModelIdArg): void ProtectedStatic | RoleModel | Called after a new Model is inserted. |
onInsertedElement(_arg: OnElementInModelIdArg): void ProtectedStatic | RoleModel | Called after an Element has been inserted into an instance of a Model of this class. |
onUpdate(arg: OnModelPropsArg): void ProtectedStatic | RoleModel | Called before a Model is updated. |
onUpdateElement(_arg: OnElementInModelPropsArg): void ProtectedStatic | RoleModel | Called when an Element in an instance of a Model of this class is about to be updated. |
onUpdated(_arg: OnModelIdArg): void ProtectedStatic | RoleModel | Called after a Model is updated. |
onUpdatedElement(_arg: OnElementInModelIdArg): void ProtectedStatic | RoleModel | Called after an Element in an instance of a Model of this class has been updated. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor ReadOnly | string | RoleModel | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor StaticReadOnly | string | RoleModel | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor ReadOnly | string | RoleModel | The name of the BIS class associated with this class. |
id | string | RoleModel | The Id of this Entity. |
iModel | IModelDb | RoleModel | The IModelDb that contains this Entity |
isInstanceOfEntity Readonly | "true" | RoleModel | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
isPrivate | boolean | RoleModel | |
isTemplate | boolean | RoleModel | |
jsonProperties Readonly | { T } | RoleModel | |
modeledElement Readonly | RelatedElement | RoleModel | |
name Readonly | string | RoleModel | |
parentModel Readonly | string | RoleModel | |
schema Static | undefined | RoleModel | The Schema that defines this class. |
schemaName Accessor ReadOnly | string | RoleModel | The name of the BIS Schema that defines this class |
Defined in
Last Updated: 20 June, 2023