PresentationTreeNodeLoaderProps Interface
Properties for usePresentationTreeNodeLoader hook.
Extends
Inherited methods
Name | Inherited from | Description |
---|---|---|
customizeTreeNodeItem(item: Partial<DelayLoadedTreeNodeItem>, node: Partial<Node>): void Optional | PresentationTreeDataProviderProps | Callback which provides a way to customize how data is mapped between Node and TreeNodeItem. |
Properties
Name | Type | Description | |
---|---|---|---|
enableHierarchyAutoUpdate | undefined | boolean | Auto-update the hierarchy when ruleset, ruleset variables or data in the iModel changes. | |
pagingSize | number | Number of nodes in a single page. | |
seedTreeModel | undefined | TreeModel | Initialize tree data with the provided tree model. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
appendChildrenCountForGroupingNodes | undefined | boolean | PresentationTreeDataProviderProps | Should grouping nodes have a suffix with grouped nodes count. |
dataSourceOverrides | undefined | Partial<PresentationTreeDataProviderDataSourceEntryPoints> | PresentationTreeDataProviderProps | By default the provider uses PresentationManager accessed through Presentation.presentation to request |
imodel | IModelConnection | PresentationTreeDataProviderProps | IModel to pull data from. |
ruleDiagnostics | undefined | { handler: ClientDiagnosticsHandler, severity?: DiagnosticsLoggerSeverity } | PresentationTreeDataProviderProps | Settings for capturing rule diagnostics. |
ruleset | string | Ruleset | PresentationTreeDataProviderProps | Id of the ruleset to use when requesting content or a ruleset itself. |
Defined in
Last Updated: 20 June, 2023