PresentationTreeDataProviderProps Interface
Properties for creating a PresentationTreeDataProvider
instance.
Extends
Methods
Name | Description | |
---|---|---|
customizeTreeNodeItem(item: Partial<DelayLoadedTreeNodeItem>, node: Partial<Node>): void Optional | Callback which provides a way to customize how data is mapped between Node and TreeNodeItem. |
Properties
Name | Type | Description | |
---|---|---|---|
appendChildrenCountForGroupingNodes | undefined | boolean | Should grouping nodes have a suffix with grouped nodes count. | |
dataSourceOverrides | undefined | Partial<PresentationTreeDataProviderDataSourceEntryPoints> | By default the provider uses PresentationManager accessed through Presentation.presentation to request |
Beta |
imodel | IModelConnection | IModel to pull data from. | |
pagingSize | undefined | number | Paging size for obtaining nodes. | |
ruleset | string | Ruleset | Id of the ruleset to use when requesting content or a ruleset itself. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
ruleDiagnostics | undefined | { handler: ClientDiagnosticsHandler, severity?: DiagnosticsLoggerSeverity } | DiagnosticsProps | Settings for capturing rule diagnostics. |
Defined in
Last Updated: 20 June, 2023