FormatDiagnosticReporter Class
Beta
An abstract SuppressionDiagnosticReporter implementation that formats the diagnostic message with the message args. If a Localization implementation is specified, the message will also be translated.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(suppressions?: Map<string, string[]>, localization?: Localization): FormatDiagnosticReporter | Initializes a new FormatDiagnosticReporter | |
formatStringFromArgs(text: string, args: ArrayLike<string>, baseIndex: number = 0): string Protected | Helper method that formats string with provided arguments where the place holders | |
reportDiagnostic(diagnostic: AnyDiagnostic, messageText: string): void ProtectedAbstract | Handles the given IDiagnostic based on the implementation requirements for a | |
reportInternal(diagnostic: AnyDiagnostic): void | Prior to reporting the IDiagnostic, the diagnostic message is formatted (with translations) |
Inherited methods
Name | Inherited from | Description |
---|---|---|
report(diagnostic: AnyDiagnostic): void | SuppressionDiagnosticReporter | Prior to reporting the IDiagnostic, the diagnostic message is formatted (with translations) |
Properties
Name | Type | Description | |
---|---|---|---|
localization | undefined | Localization | The Localization object to use for message translation. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
suppressions Accessor ReadOnly | undefined | Map<string, string[]> | SuppressionDiagnosticReporter | Gets the collection of ISchemaDiagnosticSuppression objects that identify rules violations to ignore during validation. |
Defined in
Last Updated: 20 June, 2023