LoggingDiagnosticReporter Class
Beta
An IDiagnosticReporter for logging IDiagnostic objects.
Extends
Methods
Name | Description | |
---|---|---|
constructor(suppressions?: Map<string, string[]>, localization?: Localization): LoggingDiagnosticReporter | Initializes a new FormatDiagnosticReporter | |
reportDiagnostic(diagnostic: AnyDiagnostic, messageText: string): void | Handles the given IDiagnostic based on the implementation requirements for a |
Inherited methods
Name | Inherited from | Description |
---|---|---|
formatStringFromArgs(text: string, args: ArrayLike<string>, baseIndex: number = 0): string Protected | FormatDiagnosticReporter | Helper method that formats string with provided arguments where the place holders |
report(diagnostic: AnyDiagnostic): void | FormatDiagnosticReporter | Prior to reporting the IDiagnostic, the diagnostic message is formatted (with translations) |
reportInternal(diagnostic: AnyDiagnostic): void | FormatDiagnosticReporter | Prior to reporting the IDiagnostic, the diagnostic message is formatted (with translations) |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
localization | undefined | Localization | FormatDiagnosticReporter | The Localization object to use for message translation. |
suppressions Accessor ReadOnly | undefined | Map<string, string[]> | FormatDiagnosticReporter | Gets the collection of ISchemaDiagnosticSuppression objects that identify rules violations to ignore during validation. |
Defined in
Last Updated: 20 June, 2023