IDiagnostic<TYPE extends AnyECType, ARGS extends any[]> Interface
Beta
The interface implemented by all diagnostics used during schema validation.
Implemented by
Properties
Name | Type | Description | |
---|---|---|---|
category | DiagnosticCategory | The diagnostic category (error, warning, etc...). | |
code | string | The unique string identifier of the diagnostic in the format ' |
|
diagnosticType | DiagnosticType | The context type of diagnostic (schema, schema item, property, etc...). | |
ecDefinition | TYPE | The EC object associated with the diagnostic instance. | |
undefined | ARGS | The arguments used when formatted the diagnostic instance's message. | ||
string | The unformatted message text associated with the diagnostic. | ||
schema | Schema | The schema where the diagnostic originated. |
Defined in
Last Updated: 20 June, 2023