SuppressionDiagnosticReporter Class
Beta
An abstract base class for IDiagnosticReporter implementation that used the provided Map to suppress certain rule violations from being reported. The Map's key a schema full name, and the Map's value is a collection of rule codes to suppress.
Extended by
Implements
Methods
Name | Description | |
---|---|---|
constructor(suppressions?: Map<string, string[]>): SuppressionDiagnosticReporter | Initializes a new SuppressionDiagnosticReporter | |
report(diagnostic: AnyDiagnostic): void | Prior to reporting the IDiagnostic, the diagnostic message is formatted (with translations) | |
reportInternal(diagnostic: AnyDiagnostic): void ProtectedAbstract | Handles the given IDiagnostic based on the implementation requirements for a |
Properties
Name | Type | Description | |
---|---|---|---|
suppressions Accessor ReadOnly | undefined | Map<string, string[]> | Gets the collection of ISchemaDiagnosticSuppression objects that identify |
Defined in
Last Updated: 20 June, 2023