NonConvexFacetLocationDetail Class
Implementation of FacetLocationDetail
for a non-convex facet.
- Facet vertex data interpolation is not available.
Extended by
Implements
Methods
Name | Description | |
---|---|---|
constructor(facetIndex: number = -1, edgeCount: number = 0, detail?: PolygonLocationDetail): NonConvexFacetLocationDetail Protected | captures the detail if provided | |
clone(): NonConvexFacetLocationDetail | Clone the instance | |
copyContentsFrom(other: NonConvexFacetLocationDetail): void | Set the instance contents from the other detail. | |
getBarycentricCoordinates(): undefined | number[] | Barycentric coordinates are not defined for a non-convex facet. | |
getColor(): undefined | number | Interpolated data is not defined for a non-convex facet. | |
getNormal(): undefined | Vector3d | Interpolated data is not defined for a non-convex facet. | |
getParam(): undefined | Point2d | Interpolated data is not defined for a non-convex facet. | |
invalidate(deep: boolean = true): void | Invalidate this detail. | |
create(facetIndex: number, edgeCount: number, detail?: PolygonLocationDetail, result?: NonConvexFacetLocationDetail): NonConvexFacetLocationDetail Static | Create a detail. |
Properties
Name | Type | Description | |
---|---|---|---|
_detail Protected | PolygonLocationDetail | ||
a Accessor ReadOnly | number | Get the application-specific number. | |
classify Accessor ReadOnly | PolygonLocation | Get the code that classifies the location of the point with respect to the facet. | |
closestEdge Accessor ReadOnly | { edgeParam: number, startVertexIndex: number } | Get the projection of the point onto the closest facet edge. | |
edgeCount Accessor ReadOnly | number | Get the edge count of this facet. | |
facetIndex Accessor ReadOnly | number | Get the facet index. | |
isConvex Accessor ReadOnly | boolean | Whether the facet is convex. | |
isInsideOrOn Accessor ReadOnly | boolean | Whether the point is inside or on the polygon. | |
isValid Accessor ReadOnly | boolean | Whether this instance specifies a valid location. | |
point Accessor ReadOnly | Point3d | Get the world coordinates of the point. |
Defined in
- polyface/FacetLocationDetail.ts Line 231
Last Updated: 20 June, 2023