ConvexFacetLocationDetail Class
Implementation of FacetLocationDetail
for a convex facet.
- If
edgeCount
is 3, TriangularFacetLocationDetail
is more efficient.
Extends
Methods
Name |
Description |
|
clone(): ConvexFacetLocationDetail |
Clone the instance |
|
copyContentsFrom(other: ConvexFacetLocationDetail): void |
Set the instance contents from the other detail. |
|
getBarycentricCoordinates(facetVertices?: IndexedXYZCollection, distanceTolerance: number = Geometry.smallMetricDistance): undefined | number[] |
Get the barycentric coordinates of this location, if they have been computed. |
|
getColor(facetColors?: number[], facetVertices?: IndexedXYZCollection, distanceTolerance: number = Geometry.smallMetricDistance): undefined | number |
Get color interpolated from facet data. |
|
getNormal(facetNormals?: IndexedXYZCollection, facetVertices?: IndexedXYZCollection, distanceTolerance: number = Geometry.smallMetricDistance): undefined | Vector3d |
Get normal interpolated from facet data. |
|
getParam(facetParams?: IndexedXYCollection, facetVertices?: IndexedXYZCollection, distanceTolerance: number = Geometry.smallMetricDistance): undefined | Point2d |
Get uv parameter interpolated from facet data. |
|
invalidate(deep: boolean = true): void |
Invalidate this detail. |
|
create(facetIndex: number, edgeCount: number, detail?: PolygonLocationDetail, result?: ConvexFacetLocationDetail): ConvexFacetLocationDetail Static |
Create a detail. |
|
Properties
Name |
Type |
Description |
|
isConvex Accessor ReadOnly |
boolean |
Whether the facet is convex. |
|
Inherited properties
Defined in
Last Updated:
20 June, 2023