PolygonLocation Enumeration
Enumeration of possible locations of a point in the plane of a polygon.
Members
Name |
Value |
Description |
Unknown |
0 |
No location specified. |
OnPolygonVertex |
1 |
Point is at a vertex. |
OnPolygonEdgeInterior |
2 |
Point is on an edge (but not a vertex). |
InsidePolygon |
3 |
Point is strictly inside the polygon with unknown projection. |
InsidePolygonProjectsToVertex |
4 |
Point is strictly inside the polygon and projects to a vertex. |
InsidePolygonProjectsToEdgeInterior |
5 |
Point is strictly inside the polygon and projects to an edge (but not a vertex). |
OutsidePolygon |
6 |
Point is strictly outside the polygon with unknown projection. |
OutsidePolygonProjectsToVertex |
7 |
Point is strictly outside the polygon and projects to a vertex. |
OutsidePolygonProjectsToEdgeInterior |
8 |
Point is strictly outside the polygon and projects to an edge (but not a vertex). |
Defined in
Last Updated:
20 June, 2023