EllipsoidPatch Class
- An
EllipsoidPatch
is
- An underlying (full)
Ellipsoid
object
- an angular range (
AngleSweep
) of longitudes around the equator
- an angular range (
AngleSweep
) of latitudes, with 0 at the equator, +90 degrees at north pole.
- The
EllipsoidPatch
implements UVSurface
methods, so a PolyfaceBuilder
can generate facets in its method addUVGridBody
Implements
Methods
Name |
Description |
|
anglesToUnitNormalRay(position: LongitudeLatitudeNumber, result?: Ray3d): undefined | Ray3d |
Compute point (with altitude) at given angles and altitude. |
|
containsAngles(position: LongitudeLatitudeNumber, allowPeriodicLongitude: boolean = true): boolean |
test if the angles of the LongitudeLatitudeNumber are within the sweep ranges. |
|
intersectRay(ray: Ray3d, restrictToPatch: boolean, convertIntersectionRadiansToFractions: boolean = false): CurveAndSurfaceLocationDetail[] |
Return intersections of the ray and surface. |
|
projectPointToSurface(spacePoint: Point3d): undefined | LongitudeLatitudeNumber |
Find the closest point of the (patch of the) ellipsoid. |
|
range(result?: Range3d): Range3d |
Return the range of the patch, considering both boundary and internal extrema. |
|
uvFractionToAngles(longitudeFraction: number, phiFraction: number, h: number = 0, result?: LongitudeLatitudeNumber): LongitudeLatitudeNumber |
Return simple angles of a fractional position in the patch. |
|
uvFractionToPoint(longitudeFraction: number, latitudeFraction: number, result?: Point3d): Point3d |
Return the point on the ellipsoid at fractional positions in the angular ranges. |
|
uvFractionToPointAndTangents(longitudeFraction: number, latitudeFraction: number, result?: Plane3dByOriginAndVectors): Plane3dByOriginAndVectors |
Return the point and derivative vectors on the ellipsoid at fractional positions in the angular ranges. |
|
createCapture(ellipsoid: Ellipsoid, longitudeSweep: AngleSweep, latitudeSweep: AngleSweep): EllipsoidPatch Static |
Create a new EllipsoidPatch, capturing (not cloning) all input object references. |
|
Properties
Defined in
Last Updated:
20 June, 2023