UVSurface Interface
Interface with methods for mapping (u,v) fractional coordinates to surface xyz and derivatives.
Implemented by
Methods
Name | Description | |
---|---|---|
uvFractionToPoint(uFraction: number, vFraction: number, result?: Point3d): Point3d | Convert fractional u and v coordinates to surface point | |
uvFractionToPointAndTangents(uFraction: number, vFraction: number, result?: Plane3dByOriginAndVectors): Plane3dByOriginAndVectors | Convert fractional u and v coordinates to surface point and in-surface tangent directions. |
Defined in
- geometry3d/GeometryHandler.ts Line 344
Last Updated: 20 June, 2023