ContextRealityModelState Class
A ContextRealityModel attached to a DisplayStyleState supplying a TileTreeReference used to draw the reality model in a Viewport.
see DisplayStyleSettings.contextRealityModels.
see DisplayStyleState.contextRealityModelStates.
see DisplayStyleState.attachRealityModel.
extensions
Extends
Inherited methods
Name | Inherited from | Description |
---|---|---|
matchesNameAndUrl(name: string, url: string): boolean | ContextRealityModel | Returns true if name and url match the specified name and url. |
toJSON(): ContextRealityModelProps | ContextRealityModel | Convert this model to its JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
iModel Readonly | IModelConnection | The iModel with which the reality model is associated. | |
isGlobal Accessor ReadOnly | boolean | Whether the reality model spans the entire globe ellipsoid. | |
modelId Accessor ReadOnly | undefined | string | The transient Id assigned to this reality model at run-time. | |
rdSourceKey Readonly | RealityDataSourceKey | The reality data source key with which the reality model is associated. | |
treeRef Accessor ReadOnly | TileTreeReference | The tile tree reference responsible for drawing the reality model into a Viewport. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_appearanceOverrides Protected | undefined | FeatureAppearance | ContextRealityModel | |
_displaySettings Protected | RealityModelDisplaySettings | ContextRealityModel | |
_planarClipMask Protected | undefined | PlanarClipMaskSettings | ContextRealityModel | |
appearanceOverrides Accessor | undefined | FeatureAppearance | ContextRealityModel | Overrides applied to the appearance of the reality model. Only the rgb, transparency, nonLocatable, and emphasized properties are applicable - the rest are ignored. |
classifiers Readonly | undefined | SpatialClassifiers | ContextRealityModel | A set of SpatialClassifiers, of which one at any given time can be used to classify the reality model. |
description Readonly | string | ContextRealityModel | A description of the model suitable for display in a user interface. |
displaySettings Accessor | RealityModelDisplaySettings | ContextRealityModel | Settings controlling how this reality model is displayed in a Viewport. |
name Readonly | string | ContextRealityModel | A name suitable for display in a user interface. |
onAppearanceOverridesChanged Readonly | BeEvent<(newOverrides: undefined | FeatureAppearance, model: ContextRealityModel) => void> | ContextRealityModel | Event dispatched just before assignment to appearanceOverrides. |
onDisplaySettingsChanged Readonly | BeEvent<(newSettings: RealityModelDisplaySettings, model: ContextRealityModel) => void> | ContextRealityModel | Event dispatched just before assignment to displaySettings. |
onPlanarClipMaskChanged Readonly | BeEvent<(newSettings: undefined | PlanarClipMaskSettings, model: ContextRealityModel) => void> | ContextRealityModel | Event dispatched just before assignment to planarClipMaskSettings. |
planarClipMaskSettings Accessor | undefined | PlanarClipMaskSettings | ContextRealityModel | Optionally describes how the geometry of the reality model can be masked by other models. |
realityDataId Readonly | undefined | string | ContextRealityModel | An optional identifier that, if present, can be used to elide a request to the reality data service. |
url Readonly | string | ContextRealityModel | The URL that supplies the 3d tiles for displaying the reality model. |
Defined in
Last Updated: 20 June, 2023