SpatialModelState Class
Represents the front-end state of a SpatialModel.
extensions
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(props: ModelProps, iModel: IModelConnection, state?: SpatialModelState): SpatialModelState | Constructor for EntityState |
Inherited methods
Name | Inherited from | Description |
---|---|---|
clone(iModel?: IModelConnection): SpatialModelState | GeometricModel3dState | Make an independent copy of this EntityState |
equals(other: SpatialModelState): boolean | GeometricModel3dState | Return true if this EntityState is equal to another one. |
queryModelRange(): Promise<Range3d> | GeometricModel3dState | Query for the union of the ranges of all the elements in this GeometricModel. |
Properties
Name | Type | Description | |
---|---|---|---|
classifiers Readonly | undefined | SpatialClassifiers | If this is a reality model, provides access to a list of available spatial classifiers that can be applied to it. | |
isRealityModel Accessor ReadOnly | boolean | Return true if this is a reality model (represented by a 3d tile set). |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
asGeometricModel2d Accessor ReadOnly | undefined | GeometricModel2dState | GeometricModel3dState | Attempts to cast this model to a 2d geometric model. |
classFullName Accessor StaticReadOnly | string | GeometricModel3dState | Get full BIS class name of this Entity in the form "SchemaName:ClassName". |
classFullName Readonly | string | GeometricModel3dState | The full class name in the form "schema:class". |
className Accessor ReadOnly | string | GeometricModel3dState | The name of the BIS class associated with this class. |
id Readonly | string | GeometricModel3dState | The Id of this Entity. |
iModel Readonly | IModelConnection | GeometricModel3dState | The iModel from which this Entity was loaded |
is2d Accessor ReadOnly | boolean | GeometricModel3dState | Returns true if this is a 2d model (a GeometricModel2dState). |
isNotSpatiallyLocated Readonly | boolean | GeometricModel3dState | If true, then the elements in this GeometricModel3dState are not in real-world coordinates and will not be in the spatial index. |
isPlanProjection Readonly | boolean | GeometricModel3dState | If true, then the elements in this GeometricModel3dState are expected to be in an XY plane. |
isPrivate Readonly | boolean | GeometricModel3dState | |
isSpatiallyLocated Accessor ReadOnly | boolean | GeometricModel3dState | If true, then the elements in this GeometricModel3dState are in real-world coordinates and will be in the spatial index. |
isTemplate Readonly | boolean | GeometricModel3dState | |
jsonProperties Readonly | { T } | GeometricModel3dState | Optional json properties of this Entity. |
modeledElement Readonly | RelatedElement | GeometricModel3dState | |
name Readonly | string | GeometricModel3dState | |
parentModel | string | GeometricModel3dState | |
schemaName Accessor StaticReadOnly | string | GeometricModel3dState | The name of the BIS schema for this class. |
Defined in
- core/frontend/src/ModelState.ts Line 281
Last Updated: 20 June, 2023