PhysicalModelState Class
Represents the front-end state of a PhysicalModel.
extensions
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: ModelProps, iModel: IModelConnection, state?: SpatialModelState): PhysicalModelState | Constructor for EntityState |
Inherited methods
Name | Inherited from | Description |
---|---|---|
clone(iModel?: IModelConnection): PhysicalModelState | SpatialModelState | Make an independent copy of this EntityState |
equals(other: PhysicalModelState): boolean | SpatialModelState | Return true if this EntityState is equal to another one. |
queryModelRange(): Promise<Range3d> | SpatialModelState | Query for the union of the ranges of all the elements in this GeometricModel. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
asGeometricModel2d Accessor ReadOnly | undefined | GeometricModel2dState | SpatialModelState | Attempts to cast this model to a 2d geometric model. |
classFullName Accessor StaticReadOnly | string | SpatialModelState | Get full BIS class name of this Entity in the form "SchemaName:ClassName". |
classFullName Readonly | string | SpatialModelState | The full class name in the form "schema:class". |
classifiers Readonly | undefined | SpatialClassifiers | SpatialModelState | If this is a reality model, provides access to a list of available spatial classifiers that can be applied to it. |
className Accessor ReadOnly | string | SpatialModelState | The name of the BIS class associated with this class. |
id Readonly | string | SpatialModelState | The Id of this Entity. |
iModel Readonly | IModelConnection | SpatialModelState | The iModel from which this Entity was loaded |
is2d Accessor ReadOnly | boolean | SpatialModelState | Returns true if this is a 2d model (a GeometricModel2dState). |
isNotSpatiallyLocated Readonly | boolean | SpatialModelState | If true, then the elements in this GeometricModel3dState are not in real-world coordinates and will not be in the spatial index. |
isPlanProjection Readonly | boolean | SpatialModelState | If true, then the elements in this GeometricModel3dState are expected to be in an XY plane. |
isPrivate Readonly | boolean | SpatialModelState | |
isRealityModel Accessor ReadOnly | boolean | SpatialModelState | Return true if this is a reality model (represented by a 3d tile set). |
isSpatiallyLocated Accessor ReadOnly | boolean | SpatialModelState | If true, then the elements in this GeometricModel3dState are in real-world coordinates and will be in the spatial index. |
isTemplate Readonly | boolean | SpatialModelState | |
jsonProperties Readonly | { T } | SpatialModelState | Optional json properties of this Entity. |
modeledElement Readonly | RelatedElement | SpatialModelState | |
name Readonly | string | SpatialModelState | |
parentModel | string | SpatialModelState | |
schemaName Accessor StaticReadOnly | string | SpatialModelState | The name of the BIS schema for this class. |
Defined in
- core/frontend/src/ModelState.ts Line 305
Last Updated: 20 June, 2023