GeometricModel2dState Class
Represents the front-end state of a GeometricModel2d.
extensions
Extends
Extended by
Implements
Methods
Name | Description | |
---|---|---|
constructor(props: GeometricModel2dProps, iModel: IModelConnection, state?: GeometricModel2dState): GeometricModel2dState | Constructor for EntityState | |
toJSON(): GeometricModel2dProps | Add all custom-handled properties of a Model to a json object. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
clone(iModel?: IModelConnection): GeometricModel2dState | GeometricModelState | Make an independent copy of this EntityState |
equals(other: GeometricModel2dState): boolean | GeometricModelState | Return true if this EntityState is equal to another one. |
queryModelRange(): Promise<Range3d> | GeometricModelState | Query for the union of the ranges of all the elements in this GeometricModel. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
asGeometricModel3d Accessor ReadOnly | undefined | GeometricModel3dState | GeometricModelState | Attempts to cast this model to a 3d geometric model. |
asSpatialModel Accessor ReadOnly | undefined | SpatialModelState | GeometricModelState | Attempts to cast this model to a spatial model. |
classFullName Accessor StaticReadOnly | string | GeometricModelState | Get full BIS class name of this Entity in the form "SchemaName:ClassName". |
classFullName Readonly | string | GeometricModelState | The full class name in the form "schema:class". |
className Accessor ReadOnly | string | GeometricModelState | The name of the BIS class associated with this class. |
id Readonly | string | GeometricModelState | The Id of this Entity. |
iModel Readonly | IModelConnection | GeometricModelState | The iModel from which this Entity was loaded |
is2d Accessor ReadOnly | boolean | GeometricModelState | Returns true if this is a 2d model (a GeometricModel2dState). |
isPrivate Readonly | boolean | GeometricModelState | |
isTemplate Readonly | boolean | GeometricModelState | |
jsonProperties Readonly | { T } | GeometricModelState | Optional json properties of this Entity. |
modeledElement Readonly | RelatedElement | GeometricModelState | |
name Readonly | string | GeometricModelState | |
parentModel | string | GeometricModelState | |
schemaName Accessor StaticReadOnly | string | GeometricModelState | The name of the BIS schema for this class. |
Defined in
- core/frontend/src/ModelState.ts Line 200
Last Updated: 20 June, 2023