MapLayerFormat Class
Beta
Class representing a map-layer format. Each format has it's unique 'formatId' string, used to uniquely identify a format in the MapLayerFormatRegistry. When creating an ImageMapLayerSettings object, a format needs to be specified this 'formatId'. The MapLayerFormat object can later be used to validate a source, or create a provider.
Subclasses should override formatId and MapLayerFormat.createImageryProvider.
Extended by
Methods
Name | Description | |
---|---|---|
constructor(): MapLayerFormat | ||
register(): void Static | Register the current format in the MapLayerFormatRegistry. | |
validateSource(_url: string, _userName?: string, _password?: string, _ignoreCache?: boolean): Promise<MapLayerSourceValidation> Static | Allow a source of a specific to be validated before being attached as a map-layer. |
Properties
Name | Type | Description | |
---|---|---|---|
formatId Static | string |
Defined in
Last Updated: 20 June, 2023