ImageryMapLayerFormat Class
Beta
Base class imagery map layer formats. Subclasses should override formatId and MapLayerFormat.createImageryProvider.
see MapLayerFormat
Extends
Methods
Name | Description | |
---|---|---|
constructor(): ImageryMapLayerFormat |
Inherited methods
Name | Inherited from | Description |
---|---|---|
register(): void Static | MapLayerFormat | Register the current format in the MapLayerFormatRegistry. |
validateSource(_url: string, _userName?: string, _password?: string, _ignoreCache?: boolean): Promise<MapLayerSourceValidation> Static | MapLayerFormat | Allow a source of a specific to be validated before being attached as a map-layer. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
formatId Static | string | MapLayerFormat |
Defined in
Last Updated: 20 June, 2023