MapLayerFormatRegistry Class
Beta
Methods
Name | Description | |
---|---|---|
constructor(opts?: MapLayerOptions): MapLayerFormatRegistry | ||
getAccessClient(formatId: string): undefined | MapLayerAccessClient | ||
isRegistered(formatId: string): boolean | ||
register(formatClass: undefined, accessClient?: MapLayerAccessClient): void | ||
setAccessClient(formatId: string, accessClient: MapLayerAccessClient): boolean | ||
validateSource(formatId: string, url: string, userName?: string, password?: string, ignoreCache?: boolean): Promise<MapLayerSourceValidation> |
Properties
Name | Type | Description | |
---|---|---|---|
configOptions Accessor ReadOnly | MapLayerOptions |
Defined in
Last Updated: 20 June, 2023