MapLayerOptions Interface
Beta
Options supplied at startup via IModelAppOptions.mapLayerOptions to specify access keys for various map layer formats. 'BingMaps' must have it's key value set to 'key' 'MapboxImagery' must have it's key value set to 'access_token'
Properties
Name | Type | Description | |
---|---|---|---|
AzureMaps | undefined | MapLayerKey | Access key for Azure Maps in the format { key: "subscription-key", value: "your-azure-maps-key" } . |
|
BingMaps | undefined | MapLayerKey | Access key for Bing Maps in the format { key: "key", value: "your-bing-maps-key" } . |
|
MapboxImagery | undefined | MapLayerKey | Access key for Mapbox in the format { key: "access_token", value: "your-mapbox-key" } . |
Defined in
Last Updated: 20 June, 2023