MapLayerAccessClient Interface
Beta
Methods
Name | Description | |
---|---|---|
getAccessToken(params: MapLayerAccessTokenParams): Promise<undefined | MapLayerAccessToken> | ||
getTokenServiceEndPoint(mapLayerUrl: string): Promise<undefined | MapLayerTokenEndpoint> Optional | ||
invalidateToken(token: MapLayerAccessToken): boolean Optional |
Properties
Name | Type | Description | |
---|---|---|---|
onOAuthProcessEnd | undefined | BeEvent<Listener> |
Defined in
Last Updated: 20 June, 2023