MapLayers
Types for working with the MapLayers API.
Classes
Name | Description | |
---|---|---|
BaseMapLayerSettings | A ImageMapLayerSettings that can serve as the base layer for a MapImagerySettings. | |
ImageMapLayerSettings | Normalized representation of a ImageMapLayerProps for which values have been validated and default values have been applied where explicit values not defined. | |
MapImagerySettings | Provides access to the map imagery settings (Base and layers). | |
MapLayerSettings | Abstract base class for normalized representation of a MapLayerProps for which values have been validated and default values have been applied where explicit values not defined. | |
MapSubLayerSettings | Normalized representation of a MapSubLayerProps for which values | |
ModelMapLayerSettings | Normalized representation of a ModelMapLayerProps for which values have been validated and default values have been applied where explicit values not defined. |
Interfaces
Name | Description | |
---|---|---|
BaseMapLayerProps | JSON representation of a BaseMapLayerSettings. | |
CommonMapLayerProps | JSON representation of properties common to both ImageMapLayerProps and ModelMapLayerProps. | |
ImageMapLayerProps | JSON representation of an ImageMapLayerSettings. | |
MapImageryProps | The JSON representation of the map imagery. | |
MapLayerKey | stores key-value pair to be added to all requests made involving map layer. | |
MapSubLayerProps | JSON representation of the settings associated with a map sublayer included within a MapLayerProps. | |
ModelMapLayerProps | JSON representation of a ModelMapLayerSettings. |
Namespaces
Name | Description | |
---|---|---|
BaseLayerSettings |
Type Aliases
Name | Description | |
---|---|---|
BaseLayerProps | JSON representation of a BaseLayerSettings. | |
BaseLayerSettings | The base layer for a MapImagerySettings. | |
ImageryMapLayerFormatId | The current set of supported map layer formats. | |
MapLayerProps | JSON representation of a MapLayerSettings. | |
SubLayerId |
Last Updated: 21 November, 2022