RenderSchedule.ScriptReference Class
A reference to a RenderSchedule.Script, optionally identifying the source of the script.
see DisplayStyle.loadScheduleScript and DisplayStyleState.scheduleScript to obtain the script reference for a display style on the frontend and backend respectively.
see DisplayStyleState.scheduleScript or DisplayStyleState.changeRenderTimeline to change a display style's script on the frontend.
Methods
Name | Description | |
---|---|---|
constructor(script: RenderSchedule.Script): RenderSchedule.ScriptReference | Create a reference to a RenderSchedule.ScriptReference.script with no RenderSchedule.ScriptReference.sourceId. | |
constructor(sourceId: string, script: RenderSchedule.Script): RenderSchedule.ScriptReference | Create a reference to a RenderSchedule.ScriptReference.script with the specified RenderSchedule.ScriptReference.sourceId. | |
constructor(sourceIdOrScript: string | RenderSchedule.Script, scriptIfSourceId?: RenderSchedule.Script): RenderSchedule.ScriptReference |
Properties
Name | Type | Description | |
---|---|---|---|
script Readonly | RenderSchedule.Script | The script defining the rendering timelines to be applied. | |
sourceId Readonly | string | The Id of the element - if any - from which the script originated. |
Defined in
- core/common/src/RenderSchedule.ts Line 1170
Last Updated: 20 June, 2023