RenderMaterialElement.Params Class
Deprecated in 3.6 because it is not useful to use a class
- just use RenderMaterialElementParams directly instead.
Parameters used to construct a RenderMaterial. The persistent JSON representation - RenderMaterialAssetProps - is quite verbose and unwieldy. This representation simplifies it somewhat.
see RenderMaterialElement.create and RenderMaterialElement.insert to create a RenderMaterial from parameters of this type.
Extended by
Methods
Name | Description | |
---|---|---|
constructor(paletteName: string): RenderMaterialElement.Params | Construct a new RenderMaterial.Params object with the specified paletteName. |
Properties
Name | Type | Description | |
---|---|---|---|
color | undefined | RgbFactorProps | If defined, the color to use for surface fill or diffuse illumination, overriding the surface's own color. | |
description | undefined | string | An optional description of this RenderMaterial | |
diffuse | undefined | number | The surface's diffuse reflectivity from 0.0 to 1.0. | |
finish | undefined | number | The specular exponent describing the surface's shininess, in the range 0 through 128. | |
normalMap | undefined | NormalMapProps & { scale?: number } | Specifies a normal map to apply to the surface to simulate more surface detail than is present in the | |
paletteName | string | A required palette name that categorizes this RenderMaterial | |
patternMap | undefined | TextureMapProps | Specifies a texture image to map onto the surface, replacing or mixing with the surface's own color and transparency. | |
reflect | undefined | number | Currently unused. | |
reflectColor | undefined | number[] | Currently unused. | |
specular | undefined | number | The surface's specular reflectivity from 0.0 to 1.0. | |
specularColor | undefined | RgbFactorProps | The color to use for specular illumination. | |
transmit | undefined | number | A transparency to be applied to the surface, ranging from 0 (fully opaque) to 1 (fully transparent). |
Defined in
- backend/src/Material.ts Line 191
Last Updated: 20 June, 2023