RenderMaterialElementParams Interface
Parameters used to create a RenderMaterial element. The persistent JSON representation - RenderMaterialAssetProps - is quite verbose and unwieldy. This representation simplifies it somewhat.
see RenderMaterialElement.create and RenderMaterialElement.insert to create a RenderMaterial from parameters of this type.
Extends
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
color | undefined | RgbFactorProps | RenderMaterialElement.Params | If defined, the color to use for surface fill or diffuse illumination, overriding the surface's own color. |
description | undefined | string | RenderMaterialElement.Params | An optional description of this RenderMaterial |
diffuse | undefined | number | RenderMaterialElement.Params | The surface's diffuse reflectivity from 0.0 to 1.0. |
finish | undefined | number | RenderMaterialElement.Params | The specular exponent describing the surface's shininess, in the range 0 through 128. |
normalMap | undefined | NormalMapProps & { scale?: number } | RenderMaterialElement.Params | Specifies a normal map to apply to the surface to simulate more surface detail than is present in the |
paletteName | string | RenderMaterialElement.Params | A required palette name that categorizes this RenderMaterial |
patternMap | undefined | TextureMapProps | RenderMaterialElement.Params | Specifies a texture image to map onto the surface, replacing or mixing with the surface's own color and transparency. |
reflect | undefined | number | RenderMaterialElement.Params | Currently unused. |
reflectColor | undefined | number[] | RenderMaterialElement.Params | Currently unused. |
specular | undefined | number | RenderMaterialElement.Params | The surface's specular reflectivity from 0.0 to 1.0. |
specularColor | undefined | RgbFactorProps | RenderMaterialElement.Params | The color to use for specular illumination. |
transmit | undefined | number | RenderMaterialElement.Params | A transparency to be applied to the surface, ranging from 0 (fully opaque) to 1 (fully transparent). |
Defined in
- backend/src/Material.ts Line 246
Last Updated: 20 June, 2023