GenericGraphicalModel3d Class
A generic container for persisting BisCore:GraphicalElement3d instances.
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: GeometricModel3dProps, iModel: IModelDb): GenericGraphicalModel3d | ||
insert(iModelDb: IModelDb, parentSubjectId: string, name: string, isPlanProjection?: boolean): string Static | Insert a BisCore:GraphicalPartition3d and a Generic:GraphicalModel3d that sub-models it. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
collectReferenceIds(referenceIds: Set<string>): void Protected | GraphicalModel3d | Collect the Ids of this entity's references at this level of the class hierarchy. |
delete(): void | GraphicalModel3d | Delete this Model from the iModel. |
forEachProperty(func: PropertyCallback, includeCustom: boolean = true): void | GraphicalModel3d | Call a function for each property of this Entity. |
getJsonProperty(name: string): any | GraphicalModel3d | |
getReferenceIds(): Set<string> | GraphicalModel3d | Get the Ids of this element's references. |
getUserProperties(namespace: string): any | GraphicalModel3d | Get a set of JSON user properties by namespace |
insert(): string | GraphicalModel3d | Insert this Model in the iModel |
queryExtents(): Range3d | GraphicalModel3d | Query for the union of the extents of the elements contained by this model. |
queryRange(): Promise<Range3d> | GraphicalModel3d | Query for the union of the extents of all elements contained within this model. |
removeUserProperties(nameSpace: string): void | GraphicalModel3d | Remove a set of JSON user properties, specified by namespace, from this Element |
setJsonProperty(name: string, value: any): void | GraphicalModel3d | |
setUserProperties(nameSpace: string, value: any): void | GraphicalModel3d | Change a set of user JSON properties of this Element by namespace. |
update(): void | GraphicalModel3d | Update this Model in the iModel. |
is(otherClass: undefined): boolean Static | GraphicalModel3d | return whether this Entity class is a subclass of another Entity class |
onDelete(arg: OnModelIdArg): void ProtectedStatic | GraphicalModel3d | Called before a Model is deleted. |
onDeleteElement(_arg: OnElementInModelIdArg): void ProtectedStatic | GraphicalModel3d | Called when an Element in an instance of a Model of this class is about to be deleted. |
onDeleted(_arg: OnModelIdArg): void ProtectedStatic | GraphicalModel3d | Called after a Model was deleted. |
onDeletedElement(_arg: OnElementInModelIdArg): void ProtectedStatic | GraphicalModel3d | Called after an Element in an instance of a Model of this class has been deleted. |
onInsert(arg: OnModelPropsArg): void ProtectedStatic | GraphicalModel3d | Called before a new Model is inserted. |
onInsertElement(_arg: OnElementInModelPropsArg): void ProtectedStatic | GraphicalModel3d | Called before a prospective Element is to be inserted into an instance of a Model of this class. |
onInserted(_arg: OnModelIdArg): void ProtectedStatic | GraphicalModel3d | Called after a new Model is inserted. |
onInsertedElement(_arg: OnElementInModelIdArg): void ProtectedStatic | GraphicalModel3d | Called after an Element has been inserted into an instance of a Model of this class. |
onUpdate(arg: OnModelPropsArg): void ProtectedStatic | GraphicalModel3d | Called before a Model is updated. |
onUpdateElement(_arg: OnElementInModelPropsArg): void ProtectedStatic | GraphicalModel3d | Called when an Element in an instance of a Model of this class is about to be updated. |
onUpdated(_arg: OnModelIdArg): void ProtectedStatic | GraphicalModel3d | Called after a Model is updated. |
onUpdatedElement(_arg: OnElementInModelIdArg): void ProtectedStatic | GraphicalModel3d | Called after an Element in an instance of a Model of this class has been updated. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor ReadOnly | string | GraphicalModel3d | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor StaticReadOnly | string | GraphicalModel3d | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor ReadOnly | string | GraphicalModel3d | The name of the BIS class associated with this class. |
geometryGuid | undefined | string | GraphicalModel3d | |
id | string | GraphicalModel3d | The Id of this Entity. |
iModel | IModelDb | GraphicalModel3d | The IModelDb that contains this Entity |
isInstanceOfEntity Readonly | "true" | GraphicalModel3d | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
isNotSpatiallyLocated Readonly | boolean | GraphicalModel3d | If true, then the elements in this GeometricModel3d are not in real-world coordinates and will not be in the spatial index. |
isPlanProjection Readonly | boolean | GraphicalModel3d | If true, then the elements in this GeometricModel3d are expected to be in an XY plane. |
isPrivate | boolean | GraphicalModel3d | |
isSpatiallyLocated Accessor ReadOnly | boolean | GraphicalModel3d | If true, then the elements in this GeometricModel3d are in real-world coordinates and will be in the spatial index. |
isTemplate | boolean | GraphicalModel3d | |
jsonProperties Readonly | { T } | GraphicalModel3d | |
modeledElement Readonly | RelatedElement | GraphicalModel3d | |
name Readonly | string | GraphicalModel3d | |
parentModel Readonly | string | GraphicalModel3d | |
schema Static | undefined | GraphicalModel3d | The Schema that defines this class. |
schemaName Accessor ReadOnly | string | GraphicalModel3d | The name of the BIS Schema that defines this class |
Defined in
Last Updated: 20 June, 2023