MutableCategorizedProperty Class
Base class for all Mutable CategorizedProperties
Extends
Extended by
- MutableCategorizedArrayProperty
- MutableCategorizedPrimitiveProperty
- MutableCategorizedStructProperty
Implements
- Partial<IMutableCategorizedPropertyItem>
Methods
Name | Description | |
---|---|---|
constructor(type: CategorizedPropertyTypes, record: PropertyRecord, parentSelectionKey: string, parentCategorySelectionKey: string, depth: number, overrideName?: string, overrideDisplayLabel?: string): MutableCategorizedProperty | ||
getChildren(): IMutableCategorizedPropertyItem[] Abstract | ||
getSelf(): IMutableCategorizedPropertyItem |
Inherited methods
Name | Inherited from | Description |
---|---|---|
getDescendants(): IMutableFlatGridItem[] Protected | MutableFlatPropertyGridItem | |
getDescendantsAndSelf(): IMutableFlatGridItem[] | MutableFlatPropertyGridItem | Gets a flat list of all FlatGridItems beneath this flat grid item including itself in depth first visiting order. |
getLastVisibleDescendantOrSelf(): IMutableFlatGridItem | MutableFlatPropertyGridItem | |
getVisibleDescendants(): IMutableFlatGridItem[] | MutableFlatPropertyGridItem | Gets a flat list of visible FlatGridItems beneath this flat grid item. |
getVisibleDescendantsAndSelf(): IMutableFlatGridItem[] | MutableFlatPropertyGridItem | Gets a flat list of visible FlatGridItems beneath this flat grid item and itself in depth first visiting order. |
Properties
Name | Type | Description | |
---|---|---|---|
derivedRecord Accessor ReadOnly | PropertyRecord | Record with overriden property description. | |
label Accessor ReadOnly | string | ||
parentCategorySelectionKey Accessor ReadOnly | string | ||
parentSelectionKey Accessor ReadOnly | string | ||
selectionKey Accessor ReadOnly | string | Unique selection key made of parent selectionKey and this property name. | |
type Abstract | CategorizedPropertyTypes |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_isExpanded Protected | boolean | MutableFlatPropertyGridItem | |
_isLastInRootCategory Protected | boolean | MutableFlatPropertyGridItem | |
_lastInNumberOfCategories Protected | number | MutableFlatPropertyGridItem | |
[DRAFTABLE] | boolean | MutableFlatPropertyGridItem | |
depth Accessor ReadOnly | number | MutableFlatPropertyGridItem | |
isExpanded Accessor | boolean | MutableFlatPropertyGridItem | |
key Readonly | string | MutableFlatPropertyGridItem |
Defined in
- ui/components-react/src/components-react/propertygrid/internal/flat-items/MutableFlatGridItem.ts Line 226
Last Updated: 20 June, 2023