MutableCategorizedPrimitiveProperty Class
Mutable wrapper object for PropertyRecord with primitive valueFormat.
Extends
Implements
Methods
Name | Description | |
---|---|---|
constructor(record: PropertyRecord, parentSelectionKey: string, parentCategorySelectionKey: string, depth: number, overrideName?: string, overrideDisplayLabel?: string): MutableCategorizedPrimitiveProperty | ||
getChildren(): IMutableCategorizedPropertyItem[] |
Inherited methods
Name | Inherited from | Description |
---|---|---|
getDescendants(): IMutableFlatGridItem[] Protected | MutableCategorizedProperty | |
getDescendantsAndSelf(): IMutableFlatGridItem[] | MutableCategorizedProperty | Gets a flat list of all FlatGridItems beneath this flat grid item including itself in depth first visiting order. |
getLastVisibleDescendantOrSelf(): IMutableFlatGridItem | MutableCategorizedProperty | |
getSelf(): IMutableCategorizedPropertyItem | MutableCategorizedProperty | |
getVisibleDescendants(): IMutableFlatGridItem[] | MutableCategorizedProperty | Gets a flat list of visible FlatGridItems beneath this flat grid item. |
getVisibleDescendantsAndSelf(): IMutableFlatGridItem[] | MutableCategorizedProperty | Gets a flat list of visible FlatGridItems beneath this flat grid item and itself in depth first visiting order. |
Properties
Name | Type | Description | |
---|---|---|---|
type Accessor ReadOnly | Primitive |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_isExpanded Protected | boolean | MutableCategorizedProperty | |
_isLastInRootCategory Protected | boolean | MutableCategorizedProperty | |
_lastInNumberOfCategories Protected | number | MutableCategorizedProperty | |
[DRAFTABLE] | boolean | MutableCategorizedProperty | |
depth Accessor ReadOnly | number | MutableCategorizedProperty | |
derivedRecord Accessor ReadOnly | PropertyRecord | MutableCategorizedProperty | Record with overriden property description. |
isExpanded Accessor | boolean | MutableCategorizedProperty | |
key Readonly | string | MutableCategorizedProperty | |
label Accessor ReadOnly | string | MutableCategorizedProperty | |
parentCategorySelectionKey Accessor ReadOnly | string | MutableCategorizedProperty | |
parentSelectionKey Accessor ReadOnly | string | MutableCategorizedProperty | |
selectionKey Accessor ReadOnly | string | MutableCategorizedProperty | Unique selection key made of parent selectionKey and this property name. |
Defined in
Last Updated: 20 June, 2023