MutableFlatPropertyGridItem Class
Base class for all FlatPropertyGrid items
Extended by
Implements
Methods
Name | Description | |
---|---|---|
constructor(_depth: number, _parentSelectionKey: undefined | string, _parentCategorySelectionKey: undefined | string): MutableFlatPropertyGridItem | ||
getChildren(): IMutableFlatGridItem[] Abstract | ||
getDescendants(): IMutableFlatGridItem[] Protected | ||
getDescendantsAndSelf(): IMutableFlatGridItem[] | Gets a flat list of all FlatGridItems beneath this flat grid item including itself in depth first visiting order. | |
getLastVisibleDescendantOrSelf(): IMutableFlatGridItem | ||
getSelf(): IMutableFlatGridItem Abstract | ||
getVisibleDescendants(): IMutableFlatGridItem[] | Gets a flat list of visible FlatGridItems beneath this flat grid item. | |
getVisibleDescendantsAndSelf(): IMutableFlatGridItem[] | Gets a flat list of visible FlatGridItems beneath this flat grid item and itself in depth first visiting order. |
Properties
Name | Type | Description | |
---|---|---|---|
_isExpanded Protected | boolean | ||
_isLastInRootCategory Protected | boolean | ||
_lastInNumberOfCategories Protected | number | ||
depth Accessor ReadOnly | number | ||
[DRAFTABLE] | boolean | ||
isExpanded Accessor | boolean | ||
key Readonly | string | ||
label Abstract | string | ||
parentCategorySelectionKey Accessor ReadOnly | undefined | string | ||
parentSelectionKey Accessor ReadOnly | undefined | string | ||
selectionKey Abstract | string | ||
type Abstract | FlatGridItemType |
Defined in
- ui/components-react/src/components-react/propertygrid/internal/flat-items/MutableFlatGridItem.ts Line 57
Last Updated: 20 June, 2023