PropertyEditorBase Class
PropertyEditor is the base class for all property editors.
Extended by
- BooleanPropertyEditor
- EnumPropertyButtonGroupEditor
- EnumPropertyEditor
- ImageCheckBoxPropertyEditor
- NumericInputPropertyEditor
- BasicPropertyEditor
- SliderPropertyEditor
- TextareaPropertyEditor
- ThemedEnumPropertyEditor
- TogglePropertyEditor
Implements
Methods
Name | Description | |
---|---|---|
constructor(): PropertyEditorBase | ||
applyEditorParams(_property: PropertyDescription, _record: PropertyRecord): void | ||
commitValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> | ||
validateValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> |
Properties
Name | Type | Description | |
---|---|---|---|
containerHandlesBlur Accessor ReadOnly | boolean | ||
containerHandlesEnter Accessor ReadOnly | boolean | ||
containerHandlesEscape Accessor ReadOnly | boolean | ||
containerHandlesTab Accessor ReadOnly | boolean | ||
containerStopsKeydownPropagation Accessor ReadOnly | boolean | ||
customDataController | undefined | DataController | ||
reactNode Accessor AbstractReadOnly | ReactNode |
Defined in
Last Updated: 20 June, 2023